Issue with call delay

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 20:15 PST

Monitoring

Between 02:00 UTC and 02:56 UTC a subset of users experienced delays with inbound and outbound calls. We have mitigated the issue and we will continue to monitor and provide updates as soon as there is more information to share.
Posted Nov 19, 2025 - 19:23 PST
This incident affected: Zoom Phone (Zoom Phone).